Τετάρτη, 25 Μαρτίου 2015

Συγγραφή διαδικασίας (διάβασμα-γέμισμα πίνακα)

Θεωρήστε τους ακόλουθους πίνακες :
* Α[70,30], ακεραίου τύπου
* Β[70], ακεραίου τύπου
Αν ο πίνακας Β περιέχει το πλήθος των τιμών εισόδου
κάθε γραμμής του Α, γράψτε διαδικασία η οποία
εμφανίζει το περιεχόμενο του πίνακα Α στην οθόνη.

Λύση

ΔΙΑΔΙΚΑΣΙΑ ΤΥΠ(Α, Β)
ΜΕΤΑΒΛΗΤΕΣ
      ΑΚΕΡΑΙΕΣ: Α[70,30], Β[70], Κ, Λ
ΑΡΧΗ
       ΓΙΑ  Κ  ΑΠΟ  1  ΜΕΧΡΙ 70
             ΓΙΑ Λ ΑΠΟ 1 ΜΕΧΡΙ Β[Κ]
                   ΓΡΑΨΕ Α[Κ, Λ]
             ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
       ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου