Πέμπτη, 30 Απριλίου 2015

Προσδιορισμός πλήθους επαναλήψεων

Πόσες φορές τυπώνεται η λέξη 'ΑΕΠΠ';
   Για κ από 1.23 μέχρι 32.7 με_βήμα 0.003
        Εμφάνισε 'ΑΕΠΠ'
   Τέλος_επανάληψης

Απάντηση

Αν πολλαπλασιάσουμε όλες τις τιμές και το βήμα μεταβολής
με το 1000, η αρχική τιμή, η τελική τιμή και το βήμα θα
γίνουν ακέραια. Είναι σα να είχαμε μια τέτοια Για..από..μέχρι:
     Για κ από 1230 μέχρι 32700 με_βήμα 3
        Εμφάνισε 'ΑΕΠΠ'
   Τέλος_επανάληψης
Επομένως η λέξη ΑΕΠΠ θα τυπωθεί:
     (32700-1230) div 3 + 1 = 31470 div 3 + 1 = 10490+1 = 10491
     φορές

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου