Πέμπτη, 30 Απριλίου 2015

Απλοποίηση

Γράψτε απλούστερα το παρακάτω σύνολο εντολών
έτσι ώστε να τυπώνει το ίδιο αποτέλεσμα
    Για κ από 10 μέχρι 100 με_βήμα 10
        Για λ από 1 μέχρι 20 με_βήμα 4
              Αν κ+λ < 15 τότε
                   Διάβασε Χ
                   Εμφάνισε λ*Χ+κ
              Τέλος_αν
        Τέλος_επανάληψης
    Τέλος_επανάληψης

Απάντηση

Η συνθήκη κ+λ < 15 = Αληθής μόνο όταν κ = 10 και λ = 1.
Κατά συνέπεια έχουμε:
     Διάβασε Χ
     Εμφάνισε Χ+10

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου