Κυριακή, 22 Φεβρουαρίου 2015

Συγγραφή διαδικασίας

Γράψτε διαδικασία που εμφανίζει όλες τις δυνατές
ακέραιες τετράδες στο διάστημα [Α, Β] (Α, Β ακέραιοι)
που έχουν άθροισμα μεγαλύτερο από 2700.

Λύση

ΔΙΑΔΙΚΑΣΙΑ Τετράδες(Α, Β)
ΜΕΤΑΒΛΗΤΕΣ
      ΑΚΕΡΑΙΕΣ: Χ, Υ, Ζ, Κ
ΑΡΧΗ
       ΓΙΑ Χ ΑΠΟ Α ΜΕΧΡΙ Β
            ΓΙΑ Υ ΑΠΟ Α ΜΕΧΡΙ Β
                 ΓΙΑ Ζ ΑΠΟ Α ΜΕΧΡΙ Β
                        ΓΙΑ Κ ΑΠΟ Α ΜΕΧΡΙ Β
                             ΑΝ Χ+Υ+Ζ+Κ > 2700 ΤΟΤΕ
                                      ΓΡΑΨΕ Χ, Υ, Ζ, Κ
                             ΤΕΛΟΣ_ΑΝ
                        ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
                 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
           ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
       ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου