Τρίτη, 28 Οκτωβρίου 2014

Μετατροπή

Ξαναγράψτε το παρακάτω σύνολο εντολών
αντικαθιστώντας την Αν..τότε..αλλιώς_αν
με εντολές Αν..τότε
     Αν Α < > Β τότε
          Εμφάνισε Α-Β
     αλλιώς_αν  Β < 100 τότε
          Εμφάνισε Α^2
     αλλιώς
          Εμφάνισε Β+1
     Τέλος_αν

Λύση

     Αν Α < > Β τότε
          Εμφάνισε Α-Β
     Τέλος_αν
     Αν  (Β < 100) ΚΑΙ (Α = Β) τότε
          Εμφάνισε Α^2
     Τέλος_αν
     Αν  (Β >= 100) ΚΑΙ (Α = Β) τότε
          Εμφάνισε Β+1
     Τέλος_αν

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου