Σάββατο, 20 Δεκεμβρίου 2014

Εμφωλευμένες δομές επανάληψης

Γράψτε αλγόριθμο που εντοπίζει τετράδες ακεραίων
αριθμών στο διάστημα [-200, 300] που έχουν άθροισμα
περιττό.

Λύση

Αλγόριθμος Ασκ
Για κ από -200  μέχρι  300
    Για λ από -200  μέχρι  300
       Για μ από -200  μέχρι  300
            Για ρ από -200  μέχρι  300
                 Αν (κ+λ+μ+ρ) mod 2 = 1 τότε
                      Εμφάνισε κ, λ, μ, ρ
                 Τέλος_αν
            Τέλος_επανάληψης
       Τέλος_επανάληψης
   Τέλος_επανάληψης
Τέλος_επανάληψης
Τέλος Ασκ

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου