Σάββατο, 27 Δεκεμβρίου 2014

Βρείτε το κέντρο του πίνακα

Θεωρήστε τον πίνακα Α[Ν, Ν], όπου Ν >=3 και
περιττός ακέραιος. Γράψτε τις εντολές που
απαιτούνται προκειμένου να εμφανίσετε την τιμή
του κεντρικού στοιχείου του Α.

Λύση

α' τρόπος

Το κεντρικό στοιχείο βρίσκεται στη μεσαία
γραμμή και στη μεσαία στήλη. Άρα αρκεί να
γράψουμε :
     Εμφάνισε Α[ (Ν+1) div 2, (N+1) div 2]

β' τρόπος

Όταν το Ν είναι περιττό, το κεντρικό στοιχείο
είναι το μοναδικό στοιχείο που ανήκει και στις
δύο κύριες διαγωνίους του πίνακα. Κατά συνέπεια
γράφουμε:
       Για κ από 1 μέχρι Ν
            Για λ από 1 μέχρι Ν
                 Αν (κ = λ) ΚΑΙ (κ+λ  = Ν+1) τότε
                     Εμφάνισε Α[κ, λ]
                 Τέλος_αν
            Τέλος_επανάληψης
       Τέλος_επανάληψης

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου