Τετάρτη, 18 Μαΐου 2011

Μετατροπή συνάρτησης σε διαδικασία

Μετατρέψτε την παρακάτω συνάρτηση σε διαδικασία
     ΣΥΝΑΡΤΗΣΗ Φ(Α, Β, Γ) : ΠΡΑΓΜΑΤΙΚΗ
     ΜΕΤΑΒΛΗΤΕΣ
            ΑΚΕΡΑΙΕΣ: Α, Β
            ΠΡΑΓΜΑΤΙΚΕΣ: Γ
     ΑΡΧΗ
            ΑΝ Α > Β ΤΟΤΕ
                    Α <-- Α+1
                    Β <-- Β*2
            ΑΛΛΙΩΣ_ΑΝ Α < Β ΤΟΤΕ
                    Α <-- Α-1
                    Β <-- Β-2
            ΑΛΛΙΩΣ
                    Α <-- 2*Α
                    Β <-- Β+7
            ΤΕΛΟΣ_ΑΝ
            Φ <-- 100*Α+200*Β+300*Γ
     ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ


Λύση


     ΔΙΑΔΙΚΑΣΙΑ Φ(Α, Β, Γ, Δ)
     ΜΕΤΑΒΛΗΤΕΣ
            ΑΚΕΡΑΙΕΣ: Α, Β, Χ, Υ
            ΠΡΑΓΜΑΤΙΚΕΣ: Γ, Δ
     ΑΡΧΗ
            Χ <-- Α
            Υ <-- Β
            ΑΝ Χ > Υ ΤΟΤΕ
                    Χ <-- Χ+1
                    Υ <-- Υ*2
            ΑΛΛΙΩΣ_ΑΝ Χ < Υ ΤΟΤΕ
                    Χ <-- Χ-1
                    Υ <-- Υ-2
            ΑΛΛΙΩΣ
                    Χ <-- Χ*Α
                    Υ <-- Υ+7
            ΤΕΛΟΣ_ΑΝ
            Δ <-- 100*Χ+200*Υ+300*Γ
     ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου