Τρίτη, 10 Μαΐου 2011

Υπολογισμός πλήθους επαναλήψεων

Πόσες φορές τυπώνει 'ΚΑΛΗΜΕΡΑ' η παρακάτω
Για..από..μέχρι;

     Για κ από 1.2 μέχρι 8.7 με_βήμα 0.2
           Εμφάνισε 'ΚΑΛΗΜΕΡΑ'
     Τέλος_επανάληψης


Απάντηση


     Αφού οι τιμές που εμπλέκονται στην δομή είναι
     πραγματικού τύπου, κάνω το ακόλουθο τρικ:
     τις πολλαπλασιάζω όλες με το 10 και τις κάνω
     ακέραιες. Στο πρόχειρο μου ξαναγράφω την εντολή
          Για κ από 12 μέχρι 87 με_βήμα 2
                Εμφάνισε 'ΚΑΛΗΜΕΡΑ'
          Τέλος_επανάληψης
     Τώρα μπορώ εύκολα να υπολογίσω το πλήθος των
      επαναλήψεων με τον τύπο:
                (87-12) div 2 + 1 = 75 div 2 + 1 = 37+1 = 38

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου