Παρασκευή, 26 Αυγούστου 2011

Συγγραφή διαδικασίας

Γράψτε διαδικασία η οποία:
α) διαβάζει τον όγκο σε λίτρα κάποιων πλαστικών δοχείων
     (η είσοδος δεδομένων ολοκληρώνεται μόλις δοθεί από
      το πληκτρολόγιο μια τιμή <= 0),
β) υπολογίζει:
    * το συνολικό πλήθος των δοχείων,
    * το μεγαλύτερο όγκο δοχείου,
    * τον αύξοντα αριθμό του δοχείου που είχε αυτό
       το μεγαλύτερο όγκο.
Παρατήρηση : Θεωρείστε ότι δόθηκαν στοιχεία για τουλάχιστον
ένα δοχείο.

Λύση

       ΔΙΑΔΙΚΑΣΙΑ ΔΟΧΕΙΑ(ΠΛΗΘ, ΜΕΓ, ΑΑΜΕΓ)
       ΜΕΤΑΒΛΗΤΕΣ
             ΑΚΕΡΑΙΕΣ: ΠΛΗΘ, ΑΑΜΕΓ
             ΠΡΑΓΜΑΤΙΚΕΣ : ΟΓΚ, ΜΕΓ
       ΑΡΧΗ
              ΠΛΗΘ <-- 0
              ΜΕΓ <-- -100
              ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
                    ΔΙΑΒΑΣΕ ΟΓΚ
                    ΑΝ ΟΓΚ > 0 ΤΟΤΕ
                          ΠΛΗΘ <-- ΠΛΗΘ+1
                          ΑΝ ΟΓΚ > ΜΕΓ ΤΟΤΕ
                                 ΜΕΓ <-- ΟΓΚ
                                 ΑΑΜΕΓ <-- ΠΛΗΘ
                          ΤΕΛΟΣ_ΑΝ
                    ΤΕΛΟΣ_ΑΝ
              ΜΕΧΡΙΣ_ΟΤΟΥ ΟΓΚ <= 0
       ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου