Δευτέρα, 22 Αυγούστου 2011

Εμφωλευμένες δομές επιλογής

Ως γνωστόν, αν η ηλικία ενός ατόμου είναι πάνω από 18 
χαρακτηρίζεται ως  ενήλικος και σε διαφορετική περίπτωση
ανήλικος. Γράψτε αλγόριθμο ο οποίος:
α) διαβάζει το φύλο (λογικού τύπου) και την ηλικία ενός 
    ατόμου,
β) εμφανίζει στη μονάδα εξόδου ένα συνολικό 
    χαρακτηρισμό για το άτομο αυτό 
    (π.χ ανήλικος άνδρας).

Λύση

    Αλγόριθμος Άτομο
    Διάβασε Φύλο
    Διάβασε Ηλικία
    Αν Φύλο = Αληθής τότε   ! Άνδρας
         Αν Ηλικία > 18 τότε
              Εμφάνισε 'Άνδρας ενήλικος'
         αλλιώς
              Εμφάνισε 'Άνδρας ανήλικος'
         Τέλος_αν
    αλλιώς   ! γυναίκα
         Αν Ηλικία > 18 τότε
              Εμφάνισε 'Γυναίκα ενήλικη'
         αλλιώς
              Εμφάνισε 'Γυναίκα ανήλικη'
         Τέλος_αν
    Τέλος_αν
    Τέλος Άτομο

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου