Τετάρτη, 24 Αυγούστου 2011

Ποιο είναι το περιεχόμενο του πίνακα

Τι θα περιέχει ο πίνακας Α[6, 6] μετά την εκτέλεση των
παρακάτω εντολών΄
      Για κ από 1 μέχρι 6
           Για λ από 1 μέχρι 6
                 Αν κ = λ τότε
                      Α[κ, λ] <-- 2*κ
                 αλλιώς_αν κ+λ = 7 τότε
                      Α[κ, λ] <-- 2*λ
                 αλλιώς
                      Α[κ, λ] <-- κ+λ
                 Τέλος_αν
           Τέλος_επανάληψης
      Τέλος_επανάληψης


Λύση


   Ο κανόνας γεμίσματος του πίνακα είναι ο ακόλουθος:
       * τα στοιχεία της 1ης κυρίας διαγωνίου παίρνουν ως τιμή
          τους το διπλάσιο του δείκτη γραμμής,
       * τα στοιχεία της 2ης κυρίας διαγωνίου παίρνουν ως τιμή
          τους το διπλάσιο του δείκτη στήλης,
       * όλα τα άλλα στοιχεία του πίνακα  παίρνουν ως τιμή
          τους το άθροισμα των συντεταγμένων τους.
   Κατά συνέπεια το περιεχόμενο του πίνακα είναι :
       
         2     3     4     5      6      12
         3     4     5     6      10    8
         4     5     6     8      8      9
         5     6     6     8      9     10
         6     4     8     9     10    11
         2     8     9    10    11    12

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου