Τρίτη, 23 Αυγούστου 2011

Άσκηση : Εμφωλευμένα Για

Γράψτε αλγόριθμο που:
α) διαβάζει το ημερήσιο πλήθος των επισκεπτών ενός
    μουσείου τους τελευταίους 3 μήνες,
β) υπολογίζει και εμφανίζει:
    * το συνολικό πλήθος των επισκεπτών για το παραπάνω
       χρονικό διάστημα,
    * το συνολικό πλήθος επισκεπτών για κάθε μήνα
       ξεχωριστά,
    * τον αύξοντα αριθμό (1-3) του μήνα όπου καταγράφηκε
       το μεγαλύτερο συνολικό πλήθος επισκεπτών.
Παρατήρηση : Για λόγους απλότητας θεωρείστε ότι κάθε
μήνας έχει 30 μέρες.

Απάντηση

       Αλγόριθμος ΜΟΥΣΕΙΟ
       Μεγ <-- -100
       Αθρ <-- 0
       Για κ από 1 μέχρι 3
            σ <-- 0
            Για λ από 1 μέχρι 30
                 Διάβασε Επισκ
                 σ <-- σ+Επισκ
                 Αθρ <-- Αθρ+Επισκ   
            Τέλος_επανάληψης
            Εμφάνισε σ
            Αν σ > Μεγ τότε
                      Μεγ <-- σ
                      ΑΑμεγ <-- κ
            Τέλος_αν
       Τέλος_επανάληψης
        Εμφάνισε Αθρ, ΑΑμεγ
       Τέλος ΜΟΥΣΕΙΟ


Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου