Δευτέρα, 22 Αυγούστου 2011

Κλιμακωτός υπολογισμός

Μια καντίνα κοστολογεί τα σουβλάκια που πουλάει με
κλιμακωτό τρόπο ως εξής:

    Σουβλάκια                         Τιμή ανά σουβλάκι
    Μέχρι και 3                                     1.0
    Από 4 έως και 7                              0.8
    Από 8 έως και 12                            0.7
    Από 13 και πάνω                             0.5

Γράψτε πρόγραμμα το οποίο διαβάζει πόσα σουβλάκια
κατανάλωσε ένας πελάτης, υπολογίζει και εμφανίζει το
συνολικό κόστος τους.
Παρατήρηση : Το πρόγραμμα πρέπει να διασφαλίζει ότι
η τιμή εισόδου είναι θετικός αριθμός.

Λύση

      ΠΡΟΓΡΑΜΜΑ ΣΟΥΒΛΑΚΙΑ
      ΜΕΤΑΒΛΗΤΕΣ
             ΑΚΕΡΑΙΕΣ: ΣΟΥΒ
             ΠΡΑΓΜΑΤΙΚΕΣ: ΧΡ
      ΑΡΧΗ
             ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
                   ΔΙΑΒΑΣΕ ΣΟΥΒ
             ΜΕΧΡΙΣ_ΟΤΟΥ ΣΟΥΒ > 0
             ΑΝ ΣΟΥΒ <= 3 ΤΟΤΕ
                   ΧΡ <-- ΣΟΥΒ*1.0
             ΑΛΛΙΩΣ_ΑΝ ΣΟΥΒ <= 7 ΤΟΤΕ
                   ΧΡ <-- 3*1.0+(ΣΟΥΒ-3)*0.8
             ΑΛΛΙΩΣ_ΑΝ ΣΟΥΒ <= 12 ΤΟΤΕ
                   ΧΡ <-- 3*1.0+4*0.8+(ΣΟΥΒ-7)*0.7
             ΑΛΛΙΩΣ
                   ΧΡ <-- 3*1.0+4*0.8+5*0.7+(ΣΟΥΒ-12)*0.5
             ΤΕΛΟΣ_ΑΝ
              ΓΡΑΨΕ ΧΡ
      ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου