Σάββατο, 27 Αυγούστου 2011

Μετατροπή

Ξαναγράψτε το παρακάτω σύνολο εντολών μόνο με εντολές
Αν..τότε

         Αν Χ = 'α' τότε
              Υ <-- '@'
         αλλιώς_αν  (Χ = 'γ') Ή (Χ = 'δ') τότε
              Υ <-- '$'
         αλλιώς_αν (Χ = 'ε') Ή (Χ = 'ζ') τότε
              Υ <-- '%'
         αλλιώς
              Υ <-- '*'
         Τέλος_αν


Λύση


         Αν Χ = 'α' τότε
              Υ <-- '@'
         Τέλος_αν
         Αν  (Χ = 'γ') Ή (Χ = 'δ') τότε
              Υ <-- '$'
         Τέλος_αν      
         Αν (Χ = 'ε') Ή (Χ = 'ζ') τότε
              Υ <-- '%'
         Τέλος_αν
         Αν (Χ < > 'α') ΚΑΙ (Χ < > 'γ') ΚΑΙ (Χ < > 'δ') ΚΑΙ
              (Χ < > 'ε') ΚΑΙ (Χ < > 'ζ') τότε
               Υ <-- '*'
         Τέλος_αν        

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου