Κυριακή, 26 Ιανουαρίου 2014

Απλοποίηση

Θεωρήστε το παρακάτω σύνολο εντολών
     Για κ από 1 μέχρι 10
          Για λ από 1 μέχρι 7
              Για μ από 1 μέχρι 3
                   Αν (κ = 3) ΚΑΙ (μ = 2) τότε
                        Εμφάνισε Α[κ, λ, μ]
                   Τέλος_αν
              Τέλος_επανάληψης
          Τέλος_επανάληψης
     Τέλος_επανάληψης
Αντικαταστήστε το με ένα μόνο Για..από..μέχρι που
να επιφέρει το ίδιο αλγοριθμικό αποτέλεσμα.

Λύση

              Για λ από μέχρι 7
                   Εμφάνισε Α[3, λ, 2]
              Τέλος_επανάληψης


Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου