Παρασκευή, 10 Μαΐου 2013

Απλοποίηση

Ξαναγράψτε το παρακάτω σύνολο εντολών με ένα
μόνο Για..από..μέχρι
     Για κ από 2 μέχρι 9 με_βήμα 3
           Για λ από 10 μέχρι 100 με_βήμα 5
                 Αν λ = 35 τότε
                      Για μ από 1 μέχρι 100
                           Αν  μ = λ τότε
                               Εμφάνισε (κ-λ)*μ
                           Τέλος_αν
                      Τέλος_επανάληψης
                 Τέλος_αν
           Τέλος_επανάληψης
     Τέλος_επανάληψης

Λύση

    Για κ από 2 μέχρι 9 με_βήμα 3
           Εμφάνισε (κ-35)*35                          

    Τέλος_επανάληψης

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου