Παρασκευή, 14 Νοεμβρίου 2014

Απλοποίηση

Ξαναγράψτε απλούστερα το παρακάτω σύνολο εντολών
     Για κ από 4 μέχρι 56 με_βήμα 60
          Για λ από 100 μέχρι 20 με_βήμα -90
               Διάβασε Χ
               Εμφάνισε (λ+Χ)^κ              
          Τέλος_επανάληψης
     Τέλος_επανάληψης
     Εμφάνισε κ+λ

Απάντηση
Η εξωτερική Για εκτελείται μία φορά, μόνο για κ = 4 και η
τελική τιμή του κ είναι 64.
Η εσωτερική Για εκτελείται μία φορά, μόνο για λ = 100 και η
τελική τιμή του λ είναι 10.
Κατά συνέπεια έχουμε:

       Διάβασε Χ
       Εμφάνισε (100+Χ)^4
       Εμφάνισε  74     ! 74 = 64+10

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου