Παρασκευή, 21 Νοεμβρίου 2014

Έξοδος αποτελεσμάτων

Τι θα εμφανίσει το παρακάτω σύνολο εντολών;
     Για κ από 10 μέχρι 20 με_βήμα 10
         Για λ από 30 μέχρι 10 με_βήμα -10
             Για μ από 20 μέχρι 25 με_βήμα 4
                  Εμφάνισε (κ+λ) div 4 + μ
             Τέλος_επανάληψης
         Τέλος_επανάληψης
     Τέλος_επανάληψης

Λύση

κ = 10
     λ = 30
          μ = 20
                Αφού (κ+λ) div 4 + μ = (10+30) div 4 + 20 =
                          40 div 4 + 20 = 10+20 = 30
           μ = 24
                Αφού (κ+λ) div 4 + μ = (10+30) div 4 + 24 =
                          40 div 4 + 24 = 10+24 = 34
     λ = 20
          μ = 20
                Αφού (κ+λ) div 4 + μ = (10+20) div 4 + 20 =
                          30 div 4 + 20 = 7+20 = 27
           μ = 24
                Αφού (κ+λ) div 4 + μ = (10+20) div 4 + 24 =
                          30 div 4 + 24 = 7+24 = 31
     λ = 10
          μ = 20
                Αφού (κ+λ) div 4 + μ = (10+10) div 4 + 20 =
                         20 div 4 + 20 = 5+20 = 25
           μ = 24
                Αφού (κ+λ) div 4 + μ = (10+10) div 4 + 24 =
                          20 div 4 + 24 = 5+24 = 29
κ = 20
     λ = 30
          μ = 20
                Αφού (κ+λ) div 4 + μ = (20+30) div 4 + 20 =
                          50 div 4 + 20 = 12+20 = 32
           μ = 24
                Αφού (κ+λ) div 4 + μ = (20+30) div 4 + 24 =
                          50 div 4 + 24 = 12+24 = 36
     λ = 20
          μ = 20
                Αφού (κ+λ) div 4 + μ = (20+20) div 4 + 20 =
                          40 div 4 + 20 = 10+20 = 30
           μ = 24
                Αφού (κ+λ) div 4 + μ = (20+20) div 4 + 24 =
                          40 div 4 + 24 = 10+24 = 34
     λ = 10
          μ = 20
                Αφού (κ+λ) div 4 + μ = (20+10) div 4 + 20 =
                         30 div 4 + 20 = 7+20 = 27
           μ = 24
                Αφού (κ+λ) div 4 + μ = (20+10) div 4 + 24 =
                          30 div 4 + 24 = 7+24 = 31
   


   



Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου