Σάββατο, 15 Νοεμβρίου 2014

Συγγραφή διαδικασίας

Γράψτε διαδικασία η οποία δέχεται ως παραμέτρους
δύο ακέραιους αριθμούς Α, Β και εμφανίζει ένα
χαρακτηρισμό για τα πρόσημα τους.
Για παράδειγμα αν Α = 7, Β = -2 θα εμφανίζεται
το μήνυμα:
      Ο πρώτος είναι θετικός και ο δεύτερος αρνητικός
Για παράδειγμα αν Α = -17, Β = 0 θα εμφανίζεται
το μήνυμα:
      Ο πρώτος είναι αρνητικός και ο δεύτερος μηδέν

Λύση

ΔΙΑΔΙΚΑΣΙΑ ΠΡΟΣΗΜΑ(Α, Β)
ΜΕΤΑΒΛΗΤΕΣ
        ΑΚΕΡΑΙΕΣ: Α, Β
ΑΡΧΗ
        ΑΝ Α > 0 ΤΟΤΕ
             ΑΝ Β > 0 ΤΟΤΕ
                  ΓΡΑΨΕ 'Ο πρώτος είναι θετικός και'
                  ΓΡΑΨΕ 'ο δεύτερος είναι θετικός'
             ΑΛΛΙΩΣ_ΑΝ Β = 0 ΤΟΤΕ
                  ΓΡΑΨΕ 'Ο πρώτος είναι θετικός και'
                  ΓΡΑΨΕ 'ο δεύτερος είναι μηδέν'
             ΑΛΛΙΩΣ
                  ΓΡΑΨΕ 'Ο πρώτος είναι θετικός και'
                  ΓΡΑΨΕ 'ο δεύτερος είναι αρνητικός'
             ΤΕΛΟΣ_ΑΝ
        ΑΛΛΙΩΣ_ΑΝ Α = 0 ΤΟΤΕ
             ΑΝ Β > 0 ΤΟΤΕ
                  ΓΡΑΨΕ 'Ο πρώτος είναι μηδέν και'
                  ΓΡΑΨΕ 'ο δεύτερος είναι θετικός'
             ΑΛΛΙΩΣ_ΑΝ Β = 0 ΤΟΤΕ
                  ΓΡΑΨΕ 'Ο πρώτος είναι μηδέν και'
                  ΓΡΑΨΕ 'ο δεύτερος είναι μηδέν'
             ΑΛΛΙΩΣ
                  ΓΡΑΨΕ 'Ο πρώτος είναι μηδέν και'
                  ΓΡΑΨΕ 'ο δεύτερος είναι αρνητικός'
             ΤΕΛΟΣ_ΑΝ
        ΑΛΛΙΩΣ
              ΑΝ Β > 0 ΤΟΤΕ
                  ΓΡΑΨΕ 'Ο πρώτος είναι αρνητικός και'
                  ΓΡΑΨΕ 'ο δεύτερος είναι θετικός'
             ΑΛΛΙΩΣ_ΑΝ Β = 0 ΤΟΤΕ
                  ΓΡΑΨΕ 'Ο πρώτος είναι αρνητικός και'
                  ΓΡΑΨΕ 'ο δεύτερος είναι μηδέν'
             ΑΛΛΙΩΣ
                  ΓΡΑΨΕ 'Ο πρώτος είναι αρνητικός και'
                  ΓΡΑΨΕ 'ο δεύτερος είναι αρνητικός'
             ΤΕΛΟΣ_ΑΝ
        ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου