Τετάρτη, 26 Νοεμβρίου 2014

Μετατροπή

Ξαναγράψτε το παρακάτω σύνολο εντολών με ισοδύναμο
τρόπο αντικαθιστώντας τις εμφωλευμένες δομές επιλογής
με μια Αν..τότε. 
Περιορισμός : Ο μοναδικός λογικός τελεστής που μπορείτε
να χρησιμοποιήσετε είναι ο ΚΑΙ
           Αν Α > 10 τότε
               Αν (Β < 5) Ή (Β = 5) τότε
                    Αν Α_Τ(Γ) < Γ τότε
                         Εμφάνισε Α, Β, Γ
                    αλλιώς
                         Αν ΟΧΙ (Γ mod 6 = 2) τότε
                                Εμφάνισε Α+Β+Γ
                         Τέλος_αν
                    Τέλος_αν
               Τέλος_αν
           Τέλος_αν

Απάντηση
Ξέρουμε ότι Α_Τ(Γ) <= Γ για κάθε τιμή του Γ, κατά συνέπεια
η εντολή  Εμφάνισε Α, Β, Γ δεν εκτελείται ποτέ. Έτσι έχουμε:

 Αν (Α > 10) ΚΑΙ (Β <= 5) ΚΑΙ (Γ mod 6 < > 2) τότε
            Εμφάνισε Α+Β+Γ                        
 Τέλος_αν



Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου