Σάββατο, 23 Αυγούστου 2014

Απλοποίηση

Ξαναγράψτε απλούστερα το παρακάτω
σύνολο εντολών

  Για κ από (7 mod 8) μέχρι (11 div 12) με βήμα -1
     Διάβασε Χ
     Αν Χ < 15 τότε
         Εμφάνισε Α_Τ(15-Χ)+4
     αλλιώς_αν Χ > 15 τότε
         Εμφάνισε Α_Τ(15-Χ)+15
     αλλιώς
         Εμφάνισε Χ*20
     Τέλος_αν
  Τέλος_επανάληψης

Απάντηση

   Για κ από μέχρι με βήμα -1
     Διάβασε Χ
     Αν Χ < 15 τότε
         Εμφάνισε 19-Χ
     αλλιώς_αν Χ > 15 τότε
         Εμφάνισε Χ
     αλλιώς
         Εμφάνισε 300
     Τέλος_αν
  Τέλος_επανάληψης

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου