Τρίτη, 15 Ιουλίου 2014

Επεξεργασία δοσμένου πλήθους δεδομένων

Γράψτε αλγόριθμο που διαβάζει 35 ακέραιους αριθμούς
και εμφανίζει το τετράγωνο και την τετραγωνική τους ρίζα
(εφόσον είναι εφικτό).

Λύση

Αλγόριθμος Επεξ
Για κ από 1 μέχρι 35
     Διάβασε Χ
     Εμφάνισε Χ^2
     Αν Χ >= 0 τότε
         Εμφάνισε Τ_Ρ(Χ)
     αλλιώς
         Εμφάνισε 'Δεν ορίζεται τετραγωνική ρίζα για το ', Χ
     Τέλος_αν
Τέλος_επανάληψης
Τέλος  Επεξ

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου