Τρίτη, 29 Ιουλίου 2014

Συγγραφή διαδικασίας

Γράψτε διαδικασία που εμφανίζει όλους τους
συνδυασμούς τιμών των Χ,Υ, Ζ στο ακέραιο
διάστημα [-90, 90] που ικανοποιούν τη σχέση
    Χ + Υ = Ζ

Λύση

ΔΙΑΔΙΚΑΣΙΑ ΕΞΙΣ
ΜΕΤΑΒΛΗΤΕΣ
       ΑΚΕΡΑΙΕΣ: Χ, Υ, Ζ
ΑΡΧΗ
      ΓΙΑ Χ ΑΠΟ -90 ΜΕΧΡΙ 90
           ΓΙΑ Υ ΑΠΟ -90 ΜΕΧΡΙ 90
               ΓΙΑ Ζ ΑΠΟ -90 ΜΕΧΡΙ 90
                      ΑΝ Χ+Υ = Ζ ΤΟΤΕ
                          ΓΡΑΨΕ Χ, Υ, Ζ
                      ΤΕΛΟΣ_ΑΝ
               ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
           ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ 
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ 

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου