Σάββατο, 28 Ιουνίου 2014

Έξοδος αποτελεσμάτων

Τι θα εμφανίσει το παρακάτω σύνολο εντολών
    Για κ από 100 μέχρι 150 με_βήμα 70
        Για λ από 140 μέχρι 100 με_βήμα -80
             Εμφάνισε κ+λ
        Τέλος_επανάληψης
    Τέλος_επανάληψης
    Εμφάνισε κ+λ

Απαντήσεις

Η εξωτερική Για πραγματοποιεί μία μόνο επανάληψη (κ = 100)
και ολοκληρώνεται με κ = 170.
Η εσωτερική  Για πραγματοποιεί μία μόνο επανάληψη (λ = 140)
και ολοκληρώνεται με λ = 60.
Κατά συνέπεια:
* αφού κ+λ = 100+140 = 240, η εσωτερική Εμφάνισε 
   τυπώνει:    240
* αφού κ+λ = 170+60 = 230, η εξωτερική Εμφάνισε
   τυπώνει : 230

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου