Δευτέρα, 31 Μαΐου 2010

Άσκηση : Πίνακας συχνοτήτων+Απάντηση σε ερώτηση

Γράψτε πρόγραμμα σε ΓΛΩΣΣΑ το οποίο:
α) διαβάζει μια ακολουθία θετικών ακεραίων
    (η είσοδος δεδομένων τερματίζεται μόλις
     δοθεί η απάντηση 'Ν' στην υποβαλλόμενη
     προς το χρήστη ερώτηση 'Τελειώσατε;'),
β) υπολογίζει και εμφανίζει τη συχνότητα
    των αριθμών 19, 20, 21, ..., 33 μέσα στην
    ακολουθία εισόδου.
Παρατήρηση : Το πρόγραμμα πρέπει να
διασφαλίζει την εγκυρότητα των εισερχό-
μενων δεδομένων.

Λύση

     ΠΡΟΓΡΑΜΜΑ ΑΣΚΗΣΗ
     ΜΕΤΑΒΛΗΤΕΣ
          ΑΚΕΡΑΙΕΣ: λ, μ, Φ[15]
          ΧΑΡΑΚΤΗΡΕΣ: Επ
     ΑΡΧΗ
         ΓΙΑ λ ΑΠΟ 1 ΜΕΧΡΙ 15
              Φ[λ] <-- 0
         ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
         ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
              ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
                    ΔΙΑΒΑΣΕ μ
              ΜΕΧΡΙΣ_ΟΤΟΥ μ > 0
              ΑΝ (μ >= 19) ΚΑΙ (μ <= 33) ΤΟΤΕ
                    Φ[μ-18] <-- Φ[μ-18]+1
              ΤΕΛΟΣ_ΑΝ
              ΓΡΑΨΕ 'Τελειώσατε;'
              ΔΙΑΒΑΣΕ Επ
         ΜΕΧΡΙΣ_ΟΤΟΥ Επ = 'Ν'
         ΓΙΑ λ ΑΠΟ 1 ΜΕΧΡΙ 15
              ΓΡΑΨΕ Φ[λ]
         ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
     ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου