Τετάρτη, 19 Μαΐου 2010

Άσκηση: Καταγράψτε βασικά στοιχεία ενός προγράμματος

Δίνεται το παρακάτω πρόγραμμα
     ΠΡΟΓΡΑΜΜΑ ΑΣΚ
     ΣΤΑΘΕΡΕΣ
           Χ = 21.3
           Υ = 'ΕΦΑΡΜΟΓΗ'
     ΜΕΤΑΒΛΗΤΕΣ
           ΑΚΕΡΑΙΕΣ: κ, λ
           ΠΡΑΓΜΑΤΙΚΕΣ: μ, ρ
     ΑΡΧΗ
           ΔΙΑΒΑΣΕ κ, λ
           μ <-- κ*λ+Χ
           ΑΝ μ > 145.8 ΤΟΤΕ
                ρ <-- μ+1.2
           ΑΛΛΙΩΣ_ΑΝ μ > 123.6 ΤΟΤΕ
                ρ <-- 3*μ-0.9
           ΑΛΛΙΩΣ
                ρ <-- 4*μ+1.1
           ΤΕΛΟΣ_ΑΝ
           ΓΡΑΨΕ μ, ρ, (μ+ρ <= 2000) ΚΑΙ (μ+ρ >= 800)
     ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ 
Καταγράψτε :
α) τις μεταβλητές,
β) τις σταθερές,
γ) τις συμβολικές σταθερές,
δ) τους αριθμητικούς τελεστές,
ε) τους συγκριτικούς τελεστές,
στ) τους λογικούς τελεστές,
ζ) τις εντολές εκχώρησης,
η) τις λογικές εκφράσεις (συνθήκες),
θ) τις εντολές εισόδου,
ι) τις εντολές εξόδου.

Απάντηση

    α) κ, λ, μ, ρ
    β) 21.3, 'ΕΦΑΡΜΟΓΗ', 145.8, 1.2, 123.6, 3, -0.9, 4, 1.1, 2000,
         800
    γ) Χ, Υ
    δ) -, * (3 φορές), + (5 φορές)
    ε) > (2 φορές), >=, <=
   στ) ΚΑΙ
   ζ)  μ <-- κ*λ+Χ, ρ <-- μ+1.2, ρ <-- 3*μ-0.9, ρ <-- 4*μ+1.1
   η)  μ > 145.8, μ > 123.6, (μ+ρ <= 2000) ΚΑΙ (μ+ρ >= 800)
   θ)  ΔΙΑΒΑΣΕ κ, λ
   ι)  ΓΡΑΨΕ μ, ρ, (μ+ρ <= 2000) ΚΑΙ (μ+ρ >= 800)

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου