Πέμπτη, 20 Μαΐου 2010

Άσκηση : πίνακας συχνοτήτων

Γράψτε πρόγραμμα σε ΓΛΩΣΣΑ το οποίο:
α) διαβάζει 35 ακέραιες θετικές  τιμές που δεν υπερβαίνουν
    το 24, και τις καταχωρεί (στήλη - στήλη) στο δυσδιάστατο
    πίνακα Α[5, 7],
β) υπολογίζει και εμφανίζει πόσες φορές υπάρχουν οι
    τιμές 12, 13, 14, ...., 21 μέσα στον πίνακα Α.
γ) υπολογίζει και εμφανίζει πόσες φορές υπάρχουν οι τιμές
    18, 19, 20, 21 και 22 μέσα στην 4η στήλη του Α.
Παρατήρηση: Το πρόγραμμα πρέπει να διασφαλίζει την
εγκυρότητα των εισερχόμενων δεδομένων.

Λύση
     
    ΠΡΟΓΡΑΜΜΑ ΣΥΧΝΟΤΗΤΕΣ
    ΜΕΤΑΒΛΗΤΕΣ
          ΑΚΕΡΑΙΕΣ : Α[5, 7], ν, τ, θ, Τιμή, Φορ[10], ΦορΣΤ[5]
    ΑΡΧΗ
          ΓΙΑ ν ΑΠΟ 1 ΜΕΧΡΙ 7
               ΓΙΑ τ ΑΠΟ 1 ΜΕΧΡΙ 5
                     ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
                            ΔΙΑΒΑΣΕ Α[τ, ν]
                     ΜΕΧΡΙΣ_ΟΤΟΥ (Α[τ, ν] > 0) ΚΑΙ (Α[τ, ν] <= 24)
               ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
          ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
          ΓΙΑ ν ΑΠΟ 1 ΜΕΧΡΙ 10
                Φορ[ν] <-- 0
          ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
          ΓΙΑ τ ΑΠΟ 1 ΜΕΧΡΙ 5
               ΓΙΑ ν ΑΠΟ 1 ΜΕΧΡΙ 7
                     Τιμή <-- Α[τ, ν]
                     ΑΝ (Τιμή >= 12) ΚΑΙ (Τιμή <= 21) ΤΟΤΕ
                           θ <-- Τιμή-11
                           Φορ[θ] <-- Φορ[θ]+1
                     ΤΕΛΟΣ_ΑΝ
               ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
           ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
           ΓΙΑ ν ΑΠΟ 1 ΜΕΧΡΙ 10
                ΓΡΑΨΕ 'Η τιμή ', ν+11, ' συναντήθηκε'
                ΓΡΑΨΕ Φορ[ν], ' φορές'
           ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
           ΓΙΑ ν ΑΠΟ 1 ΜΕΧΡΙ 5
                ΦορΣΤ[ν] <-- 0
           ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
           ΓΙΑ τ ΑΠΟ 1 ΜΕΧΡΙ 5
                 Τιμή <-- Α[τ, 4]
                 ΑΝ (Τιμή >= 18) ΚΑΙ (Τιμή <= 22) ΤΟΤΕ
                           θ <-- Τιμή-17
                           ΦορΣΤ[θ] <-- ΦορΣΤ[θ]+1
                 ΤΕΛΟΣ_ΑΝ
           ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
           ΓΙΑ ν ΑΠΟ 1 ΜΕΧΡΙ 5
                ΓΡΑΨΕ 'Η τιμή ', ν+17, ' συναντήθηκε'
                ΓΡΑΨΕ ΦορΣΤ[ν], ' φορές'
           ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
   

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου