Τρίτη, 25 Μαΐου 2010

Άσκηση : Κλιμακωτός υπολογισμός

Κατά τη διάρκεια των εκπτώσεων ένα εμπορικό
κατάστημα παρέχει τη δυνατότητα κλιμακωτής
έκπτωσης για αθλητικά μπλουζάκια. Πιο συγκεκριμένα:
* τα πρώτα 3 μπλουζάκια πωλούνται με έκπτωση
   20%,
* για τα επόμενα 2 μπλουζάκια το ποσοστό της
   έκπτωσης ανέρχεται σε 30%,
* πάνω από τα 5 μπλουζάκια, το ποσοστό της
   έκπτωσης είναι 40%.
Γράψτε πρόγραμμα το οποίο:
α) διαβάζει το ονοματεπώνυμο κάθε πελάτη, πόσα
    μπλουζάκια επιθυμεί να αγοράσει και την αρχική
    τιμή πώλησης καθενός (η είσοδος δεδομένων
    ολοκληρώνεται μόλις δοθεί η απάντηση 'Ο' στην
    υποβαλλόμενη προς το χρήστη ερώτηση  'Υπάρχει
    άλλος πελάτης;'),
β) υπολογίζει και εμφανίζει:
    * τη χρέωση κάθε πελάτη,
    * το ονοματεπώνυμο του πελάτη που διέθεσε το
       μεγαλύτερο χρηματικό ποσό για να προμηθευ-
       τεί τέτοια μπλουζάκια,
    * τη μέση χρέωση πελάτη.
Παρατήρηση : Δεν απαιτείται κανένας έλεγχος εγκυρότητας
των εισερχόμενων δεδομένων.

Λύση

     ΠΡΟΓΡΑΜΜΑ Μπλουζάκια
     ΜΕΤΑΒΛΗΤΕΣ
           ΑΚΕΡΑΙΕΣ: Πλήθος, Πόσα
           ΠΡΑΓΜΑΤΙΚΕΣ: Τιμή, Έκπτωση, Τελική, Σύνολο,
                                          Μέση, ΜΑΧ
           ΧΑΡΑΚΤΗΡΕΣ: Ονομ, ΟνοΜΑΧ, Απάντηση
     ΑΡΧΗ
           Πλήθος <-- 0
           Σύνολο <-- 0
           ΜΑΧ <--  -1
           ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
                 ΔΙΑΒΑΣΕ Ονομ
                 ΔΙΑΒΑΣΕ Πόσα
                 ΔΙΑΒΑΣΕ Τιμή
                 Πλήθος <-- Πλήθος+1
                 ΑΝ Πόσα <= 3 ΤΟΤΕ
                       Έκπτωση <-- Πόσα*20/100
                 ΑΛΛΙΩΣ_ΑΝ Πόσα <= 5 ΤΟΤΕ
                       Έκπτωση <-- 3*20/100+(Πόσα-3)*30/100
                 ΑΛΛΙΩΣ
                       Έκπτωση <-- 3*20/100+2*30/100+
                                                 (Πόσα-5)*40/100
                 ΤΕΛΟΣ_ΑΝ
                 Τελική <-- Τιμή-Έκπτωση
                 ΓΡΑΨΕ Τελική
                 Σύνολο <-- Σύνολο+Τελική
                 ΑΝ Τελική > ΜΑΧ ΤΟΤΕ
                       ΜΑΧ <-- Τελική
                       ΟνοΜΑΧ <-- Ονομ
                 ΤΕΛΟΣ_ΑΝ
                 ΓΡΑΨΕ 'Υπάρχει άλλος πελάτης;'
                 ΔΙΑΒΑΣΕ Απάντηση
           ΜΕΧΡΙΣ_ΟΤΟΥ Απάντηση = 'Ο'
           Μέση <-- Σύνολο/Πλήθος
           ΓΡΑΨΕ Μέση, ΟνοΜΑΧ
     ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου