Δευτέρα, 24 Μαΐου 2010

Άσκηση : Αναγωγή στη μονάδα

Ένα σούπερ μάρκετ εμπορεύεται 11 διαφορετικές συσκευασίες
απορρυπαντικού πλυντηρίου. Γράψτε πρόγραμμα το οποίο:
α) διαβάζει την επωνυμία, την  τιμή πώλησης και το βάρος (σε
    κιλά) κάθε συσκευασίας,
β) εμφανίζει την επωνυμία της συσκευασίας εκείνης που
    αποτελεί την πιο συμφέρουσα επιλογή για ένα πελάτη.
Παρατήρηση Το πρόγραμμα πρέπει να διασφαλίζει την
εγκυρότητα των εισερχόμενων δεδομένων και συγκεκριμένα
θα πρέπει:
     * οι επωνυμίες να είναι διάφορες από το κενό διάστημα,
     * οι τιμές πώλησης να είναι θετικοί αριθμοί και να μην
        υπερβαίνουν τα 24 ευρώ,
     * τα βάρη να είναι θετικοί αριθμοί και να μην υπερβαίνουν
        τα 13,5 κιλά.

Λύση

    ΠΡΟΓΡΑΜΜΑ  Συμφέρον
    ΜΕΤΑΒΛΗΤΕΣ
          ΑΚΕΡΑΙΕΣ: λ
          ΧΑΡΑΚΤΗΡΕΣ: Επ, ΕπΣυμφ
          ΠΡΑΓΜΑΤΙΚΕΣ: Τιμή, ΤιμΚιλ, Κιλά, Μικρ
    ΑΡΧΗ
          Μικρ <-- 25
          ΓΙΑ λ ΑΠΟ 1 ΜΕΧΡΙ 11
                ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
                    ΔΙΑΒΑΣΕ Επ
                ΜΕΧΡΙΣ_ΟΤΟΥ Επ < > '  '
                ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
                    ΔΙΑΒΑΣΕ Τιμή
                ΜΕΧΡΙΣ_ΟΤΟΥ (Τιμή > 0) ΚΑΙ (Τιμή <= 24)
                ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
                    ΔΙΑΒΑΣΕ Κιλά
                ΜΕΧΡΙΣ_ΟΤΟΥ (Κιλά > 0) ΚΑΙ (Κιλά <= 13.5)
                ΤιμΚιλ <-- Τιμή/Κιλά
                ΑΝ ΤιμΚιλ < Μικρ ΤΟΤΕ
                     Μικρ <-- ΤιμΚιλ
                     ΕπΣυμφ <-- Επ
                ΤΕΛΟΣ_ΑΝ
          ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
          ΓΡΑΨΕ ΕπΣυμφ
    ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου