Δευτέρα, 17 Μαΐου 2010

Άσκηση : Τι θα εμφανιστεί στη μονάδα εξόδου;

Θεωρήστε τον ακέραιο πίνακα Α[10, 10] που όλα τα
στοιχεία του έχουν την τιμή 20. Τι θα εμφανίσει το
παρακάτω σύνολο εντολών στη μονάδα εξόδου;
      σ <-- 0
      Για κ από 1 μέχρι 10
          Για μ από 1 μέχρι 10
               Αν κ = μ τότε
                    σ <-- σ+Α[Κ, Λ]
               Τέλος_αν
          Τέλος_επανάληψης
      Τέλος_επανάληψης
      Γράψε σ, σ mod 2 = 0, Α_Τ(σ-300)

Απάντηση
     Μετά την ολοκλήρωση των δύο εμφωλευμένων βρόχων,
     το σ έχει ως τιμή  του το αποτέλεσμα του αθροίσματος
     των στοιχείων της 1ης κύριας διαγωνίου του πίνακα.
     Άρα    σ = 20+20+...+20 = 10Χ20 = 200.
     Αφού (σ mod 2 = 0) = (200 mod 2 = 0) = (0 = 0 ) = Αληθής
     και Α_Τ(σ-300) = Α_Τ(200-300) = Α_Τ(-100) = 100,
     η Γράψε εμφανίζει:   200    Αληθής    100

   

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου