Δευτέρα, 31 Μαΐου 2010

Άσκηση : Γέμισμα πίνακα με δοσμένες τιμές

Ας θεωρήσουμε τον πίνακα Α[30]. Γράψτε εντολές στη
ΓΛΩΣΣΑ οι  οποίες θα γεμίσουν τον πίνακα με τις
τιμές 1, 2, 3, ..., 30.
Παρατήρηση : Δώστε όσες περισσότερες λύσεις
μπορείτε.

Λύση

    α' τρόπος

        ΓΙΑ λ ΑΠΟ 1 ΜΕΧΡΙ 30
              Α[λ] <-- λ
        ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

    β' τρόπος

        ΓΙΑ λ ΑΠΟ 1 ΜΕΧΡΙ 30
              Α[λ] <-- λ mod 31
        ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

    γ' τρόπος

        Α[1] <-- 1
        ΓΙΑ λ ΑΠΟ 2 ΜΕΧΡΙ 30
              Α[λ] <-- Α[λ-1]+1
        ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

    δ' τρόπος

       μ <-- 1
       ΓΙΑ λ ΑΠΟ 1 ΜΕΧΡΙ 30
              Α[λ] <-- μ
              μ <-- μ+1
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

   



      

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου