Πέμπτη, 20 Μαΐου 2010

Άσκηση : αναζήτηση τιμής σε πίνακα

Ας θεωρήσουμε τους πίνακες  Λ[100], ΜΑΘ[100] που
περιέχουν τις επωνυμίες 100 γενικών λυκείων και το
πλήθος των φοιτούντων σε αυτά μαθητών αντίστοιχα.
Γράψτε αλγόριθμο που με δεδομένους τους παραπάνω
πίνακες:
α) διαβάζει την επωνυμία ενός λυκείου και την καταχωρεί
    στην αλφαριθμητική μεταβλητή ΛΥΚΕΙΟ,
β) ελέγχει αν το ΛΥΚΕΙΟ είναι ένα από τα  παραπάνω
    100 γενικά λύκεια,
γ) σε περίπτωση που η απάντηση στο ερώτημα β) είναι
    καταφατική, εμφανίζεται στη μονάδα εξόδου το πλήθος
    των φοιτούντων μαθητών του σχολείου αυτού,
δ) αν η απάντηση στο ερώτημα β) είναι αρνητική,
    εμφανίζεται στη μονάδα εξόδου το μήνυμα:
        Η επωνυμία αυτή δεν αντιστοιχεί σε λύκειο


Λύση

     Αλγόριθμος ΓενΛΥΚΕΙΑ
     Δεδομένα // Λ, ΜΑΘ //
     Διάβασε ΛΥΚΕΙΟ
     απ <-- Ψευδής
     μ <-- 1
     Όσο (μ <= 100) ΚΑΙ (απ = Ψευδής) επανάλαβε
           Αν Λ[μ] = ΛΥΚΕΙΟ τότε
                απ <-- Αληθής
                θ <-- μ
           αλλιώς
                μ <-- μ+1
           Τέλος_αν
     Τέλος_επανάληψης
     Αν  απ = Αληθής τότε
            Γράψε  Λ[θ]
     αλλιώς
            Γράψε 'Η επωνυμία αυτή δεν αντιστοιχεί σε λύκειο'
     Τέλος_αν
     Τέλος ΓενΛΥΚΕΙΑ

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου