Κυριακή, 30 Μαΐου 2010

Άσκηση : Βήμα-βήμα εκτέλεση εντολών (Για+Επιλεξε)

Τι εμφανίζει το παρακάτω σύνολο εντολών στη μονάδα
εξόδου;
     Α <-- 21
     Για λ από 3 μέχρι 8 με_βήμα 4
         Για μ από 17 μέχρι 9 με_βήμα -6
               Επίλεξε λ+μ
                    Περίπτωση 20
                          Α <-- Α-μ+λ
                          Εμφάνισε (μ-10)^2, λ > 10
                    Περίπτωση 24
                          Α <-- Α+μ-λ
                          Εμφάνισε (μ-12)*3, λ < 20
                    Περίπτωση 14
                          Α <-- Α+μ*λ
                          Εμφάνισε μ div 2, λ mod 2010
                    Περίπτωση αλλιώς
                          A <-- A+100
                          Εμφάνισε Α_Τ(λ-μ), Α_Μ(11.3-μ)+λ
               Τέλος_επιλογών
         Τέλος_επανάληψης
     Τέλος_επανάληψης
     Εμφάνισε Α, μ, λ

Λύση

     Α = 21
     1η επανάληψη εξωτερικής Για (λ = 3)
            1η επανάληψη εσωτερικής Για (μ = 17)
                   Επειδή λ+μ = 3+17 = 20 έχουμε:
                         Α = Α-μ+λ = 21-17+3 = 7
                         Αφού (μ-10)^2 = (17-10)^2 = 7^2 = 49,
                                    λ > 10 = 3 > 10 = Ψευδής,
                         η Εμφάνισε τυπώνει:
                                   49        Ψευδής
           2η επανάληψη εσωτερικής Για (μ = 11)
                   Επειδή λ+μ = 3+11= 14 έχουμε:
                         Α = Α+μ*λ = 7+11*3 = 7+33 = 40
                         Αφού μ div 2 = 11 div 2 = 5 και
                                   λ mod 2010 = 3 mod 2010 = 3
                         η Εμφάνισε τυπώνει:
                                  5        3
           Η εσωτερική Για τερματίζεται με μ = 5.
   2η επανάληψη εξωτερικής Για (λ = 7)
            1η επανάληψη εσωτερικής Για (μ = 17)
                   Επειδή λ+μ = 7+17 = 24 έχουμε:
                         Α = Α+μ-λ = 40+17-7 = 50
                         Αφού (μ-12)*3 = (17-12)*3 = 5*3 = 15 και
                                    λ < 20 = 7 < 20 = Αληθής,
                         η Εμφάνισε τυπώνει:
                                   15      Αληθής
           2η επανάληψη εσωτερικής Για (μ = 11)
                   Επειδή λ+μ = 7+11= 18 έχουμε:
                         A = A+100 = 50+100 = 150
                         Αφού Α_Τ(λ-μ) = Α_Τ(7-11) = Α_Τ(-4) = 4
                             και Α_Μ(11.3-μ)+λ = Α_Μ(11.3-11)+7 =
                                   Α_Μ(0.3)+7 = 0+7 = 7
                         η Εμφάνισε τυπώνει:
                                  4        7
           Η εσωτερική Για τερματίζεται με μ = 5.
    Η εξωτερική Για τερματίζεται με λ = 11.
    Η Εμφάνισε τυπώνει:
          150      5       11

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου