Σάββατο, 15 Μαΐου 2010

Άσκηση μετατροπής Μέχρις_ότου σε α) Όσο..επανάλαβε και β) Για..από..μέχρι

Αντικαταστήστε την Μέχρις_ότου που ακολουθεί
      κ <-- ν
      Αρχή_επανάληψης
           Εμφάνισε  (κ-ν)^2
           κ <-- κ-2
      Μέχρις_ότου κ < 5
με μια εντολή
       α) Όσο..επανάλαβε
       β) Για..από..μέχρι
έτσι ώστε να επιφέρει το ίδιο αλγοριθμικό αποτέλεσμα.


Λύση
 
      α)
              κ <-- ν
              Εμφάνισε  (κ-ν)^2
              κ <-- κ-2
              Όσο κ >= 5 επανάλαβε
                  Εμφάνισε  (κ-ν)^2
                  κ <-- κ-2
              Τέλος_επανάληψης

      β)
              κ <-- ν
              Εμφάνισε  (κ-ν)^2 
             Για κ από ν-2 μέχρι 5 με_βήμα -2
                    Εμφάνισε (κ-ν)^2
              Τέλος_επανάληψης

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου