Κυριακή, 30 Μαΐου 2010

Άσκηση : Βήμα-βήμα εκτέλεση εντολών (Οσο+Αν..τότε..αλλιώς)

Τι θα εμφανίσει το παρακάτω σύνολο εντολών;
      κ <-- 9
      λ <-- 4
      'Οσο κ > 0 επανάλαβε
            Αν κ > 4 τότε
                 Εμφάνισε κ+1, 'τεστ', λ mod 4 = 0
            αλλιώς
                 Εμφάνισε λ-1, 'αβγ', κ div 10 = 0
            Τέλος_αν
            κ <-- κ-4
            λ <-- λ+3
       Τέλος_επανάληψης
       Εμφάνισε κ, λ

Λύση

       κ = 9
       λ = 4
       1η επανάληψη 
            Επειδή κ > 4 = 9 > 4 = Αληθής και κ+1 = 9+1 = 10,
            mod 4 = 0) = (4 mod 4 = 0) = (0 = 0) = Αληθής,
            η Εμφάνισε τυπώνει:
                   10   τεστ    Αληθής
            κ = κ-4 = 9-4 = 5
            λ = λ+3 = 4+3 = 7
       2η επανάληψη 
            Επειδή κ > 4 = 5 > 4 = Αληθής και κ+1 = 5+1 = 6,
            mod 4 = 0) = (7 mod 4 = 0) = (3 = 0) = Ψευδής,
            η Εμφάνισε τυπώνει:
                   6     τεστ    Ψευδής
            κ = κ-4 = 5-4 = 1
            λ = λ+3 = 7+3 = 10
        3η επανάληψη 
            Επειδή κ > 4 = 1 > 4 = Ψευδής και λ-1 = 10-1 = 9,
            div 10 = 0) = (1 div 10 = 0) = (0 = 0) = Αληθής,
            η Εμφάνισε τυπώνει:
                   9     αβγ    Αληθής
            κ = κ-4 = 1-4 = -3
            λ = λ+3 = 10+3 = 13
         Η Όσο τερματίζεται αφού κ > 0 = -3 > 0 = Ψευδής.
         Η Εμφάνισε τυπώνει:
                -3      13

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου