Σάββατο, 15 Μαΐου 2010

Άσκηση μετατροπής Επίλεξε σε α) Αν..τότε..αλλιώς_αν β) Αν..τότε

Αντικαταστήστε την εντολή Επίλεξε που ακολουθεί:
        Επίλεξε  Χ
             Περίπτωση 22, 27
                   Υ <-- Χ*12
             Περίπτωση -1, 0, 13
                   Υ <-- Χ+12
             Περίπτωση αλλιώς
                   Υ <-- Χ^4
        Τέλος_επιλογών
με:
       α) μια εντολή Αν..τότε..αλλιώς_αν 
       β) με εντολές Αν..τότε 
έτσι ώστε να προκύπτει το ίδιο αλγοριθμικό αποτέλεσμα

Λύση


      α)
            Αν  (Χ = 22) Ή (Χ = 27) τότε
                   Υ <-- Χ*12
            αλλιώς_αν  (Χ = -1) Ή (Χ = 0) Ή (Χ = 13) τότε
                   Υ <-- Χ+12
            αλλιώς
                   Υ <-- Χ^4
            Τέλος_αν

      β)
            Αν  (Χ = 22) Ή (Χ = 27) τότε

                   Υ <-- Χ*12
            Τέλος_αν           
            Αν  (Χ = -1) Ή (Χ = 0) Ή (Χ = 13) τότε
                   Υ <-- Χ+12
            Τέλος_αν
            Αν (Χ < > 22) ΚΑΙ (Χ < > 27) ΚΑΙ (Χ < > -1) ΚΑΙ (Χ < > 0) ΚΑΙ (Χ < > 13) τότε
                   Υ <-- Χ^4
            Τέλος_αν
                   




Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου