Σάββατο, 15 Μαΐου 2010

Μικρές ασκήσεις με GOTO

Σε όλες τις παρακάτω ασκήσεις, ζητούμενο είναι η επαναδιατύπωση των εντολών με τέτοιο τρόπο ώστε να ακολουθούν τις αρχές του δομημένου προγραμματισμού (τι σημαίνει πρακτικά αυτό : εξαφανίστε την GOTO εξασφαλίζοντας ωστόσο το ίδιο τελικό αποτέλεσμα). Οι λύσεις δίνονται στο τέλος.


Άσκηση 1η 


       μ <-- 1
       ΔΙΑΒΑΣΕ ν
  5: ΑΝ μ > ν ΤΟΤΕ GOTO  7
      ΓΡΑΨΕ μ+ν
      μ <-- μ+1
      GOTO 5
  7: ΓΡΑΨΕ ν^2

Άσκηση 2η

      μ <-- 100
   4: ΔΙΑΒΑΣΕ ν
       ΑΝ ν MOD 7 = 0 TOTE GOTO 5
       μ <-- μ+ν
       GOTO 6
   5: μ <-- μ-ν
   6: ΑΝ μ <= 150 ΤΟΤΕ GOTO 4
       ΓΡΑΨΕ μ


Λύσεις

       Άσκηση 1η
              
              μ <-- 1
              ΔΙΑΒΑΣΕ ν
              ΟΣΟ μ <= ν ΕΠΑΝΑΛΑΒΕ
                   ΓΡΑΨΕ μ+ν
                   μ <-- μ+1
              ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
               ΓΡΑΨΕ ν^2 
  
       Άσκηση 2η


               μ <-- 100
               ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
                     ΔΙΑΒΑΣΕ ν
                     ΑΝ ν MOD 7 = 0 TOTE
                          μ <-- μ-ν
                     ΑΛΛΙΩΣ
                          μ <-- μ+ν
                     ΤΕΛΟΣ_ΑΝ
               ΜΕΧΡΙΣ_ΟΤΟΥ μ > 150
               ΓΡΑΨΕ μ

1 σχόλιο: