Πέμπτη, 20 Μαΐου 2010

Άσκηση : έλεγχος ιδιότητας ανά γραμμή και ανά στήλη

Γράψτε αλγόριθμο  που:
α) διαβάζει τα μηνιαία έσοδα  8   γυμναστηρίων  της
     πόλης σας, για τη χρονιά που πέρασε (πρέπει  να
      διασφαλίζεται ότι οι τιμές εισόδου είναι θετικοί
       αριθμοί),
β) υπολογίζει και εμφανίζει πόσα γυμναστήρια είχαν
    τουλάχιστον 4 φορές μηνιαία έσοδα μεγαλύτερα
    από 5000 ευρώ,
γ) υπολογίζει και εμφανίζει το ποσοστό (%) των μηνών
    στους οποίους τουλάχιστον ένα γυμναστήριο κατέ-
    γραψε μηνιαία έσοδα κάτω από 2000 ευρώ.


Λύση

     
    Αλγόριθμος Γυμναστήρια
    Για κ από 1 μέχρι 8
        Για β από 1 μέχρι 12
              Αρχή_επανάληψης
                   Διάβασε Έσοδα[κ, β]
              Μέχρις_ότου  (Έσοδα[κ, β] > 0)
        Τέλος_επανάληψης
    Τέλος_επανάληψης
    Γυμν <-- 0
    Για κ από 1 μέχρι 8
         φ <-- 0
         Για β από 1 μέχρι 12
              Αν Έσοδα[κ, β] > 5000 τότε
                   φ <-- φ+1
              Τέλος_αν
         Τέλος_επανάληψης
         Αν φ >= 4  τότε
              Γυμν <-- Γυμν+1
         Τέλος_αν
    Τέλος_επανάληψης
    Γράψε Γυμν
    Μην <-- 0
    Για β από 1 μέχρι 12
          απ <-- Ψευδής
          κ <-- 1
          Όσο (κ <= 8) ΚΑΙ (απ = Ψευδής) επανάλαβε
                Αν Έσοδα[κ, β] < 2000 τότε
                      απ <-- Αληθής
                αλλιώς
                      κ <-- κ+1
                Τέλος_αν
          Τέλος_επανάληψης
          Αν απ = Αληθής τότε
                Μην <-- Μην+1
          Τέλος_αν
    Τέλος_επανάληψης
    Ποσοστό <--  100*Μην/12
    Γράψε Ποσοστό
    Τέλος Γυμναστήρια

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου