Τρίτη, 18 Μαΐου 2010

Άσκηση : μετατροπή διαδικασίας σε συνάρτηση

Μετατρέψτε την παρακάτω διαδικασία σε συνάρτηση
    ΔΙΑΔΙΚΑΣΙΑ  ΥΠΟΛ(α, β, γ)
    ΜΕΤΑΒΛΗΤΕΣ
        ΠΡΑΓΜΑΤΙΚΕΣ: α, λ
        ΑΚΕΡΑΙΕΣ: β, κ
        ΛΟΓΙΚΕΣ: γ
    ΑΡΧΗ
        κ <-- β^2
        λ <-- 4*α
        ΑΝ κ+λ > 10000 ΤΟΤΕ
              γ <-- ΑΛΗΘΗΣ
        ΑΛΛΙΩΣ
              γ <-- ΨΕΥΔΗΣ
        ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

Λύση

    ΣΥΝΑΡΤΗΣΗ ΥΠΟΛ(α, β) : ΛΟΓΙΚΗ
    ΜΕΤΑΒΛΗΤΕΣ
        ΠΡΑΓΜΑΤΙΚΕΣ: α, λ
        ΑΚΕΡΑΙΕΣ: β, κ
    ΑΡΧΗ
        κ <-- β^2
        λ <-- 4*α
        ΑΝ κ+λ > 10000 ΤΟΤΕ
              ΥΠΟΛ <-- ΑΛΗΘΗΣ
        ΑΛΛΙΩΣ
              ΥΠΟΛ <-- ΨΕΥΔΗΣ
        ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου