Τετάρτη, 19 Μαΐου 2010

Άσκηση : Έλεγχος ιδιότητας σε ένα πίνακα

Ας θεωρήσουμε έναν ακέραιο πίνακα Μ[300]. Γράψτε αλγόριθμο
που  ελέγχει αν ισχύει η ιδιότητα :  
       Μ[ρ] = 2*Μ[ρ+1]+3,
για όλα τα στοιχεία  του πίνακα

Λύση

   Αλγόριθμος Ιδιότητα
   Δεδομένα // Μ //
   flag <-- Αληθής
   ρ <-- 1
   Όσο (flag = Αληθής) ΚΑΙ (ρ <= 299) επανάλαβε
        Αν Μ[ρ] < > 2*Μ[ρ+1]+3 τότε
              flag <-- Ψευδής
        αλλιώς
              ρ <-- ρ+1
        Τέλος_αν
   Τέλος_επανάληψης
   Αν flag = Αληθής τότε
        Γράψε 'Η ιδιότητα ισχύει'
   αλλιώς
        Γράψε 'Η ιδιότητα δεν ισχύει'
   Τέλος_αν
   Τέλος Ιδιότητα

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου