Σάββατο, 29 Μαΐου 2010

Λύσεις Απολυτήριων εξετάσεων Δ' τάξης Εσπερινού Γενικού Λυκείου 2010

ΘΕΜΑ Α

Α1.
     1. Λ
     2. Σ
     3. Λ
     4. Σ
     5. Σ

Α2. 
     1. Λ
     2. Σ
     3. Σ
     4. Σ
     5. Σ

Α3.
     1. (x > -1) KAI (x <= 10)
     2. (x = 1) Ή (x = 5) Ή (x = -40)
     3. (x > 50) KAI (x < > 100)
     4. (x > 0) KAI (x MOD 3 = 0)
     5. (x MOD 4 = 0) KAI (x MOD 100 < > 0)

A4. 
     Σ <-- 0
     Για Α από 2 μέχρι 15 με_βήμα 3
            Σ <-- Σ+Α
     Τέλος_επανάληψης
     Εμφάνισε Σ

ΘΕΜΑ Β

Β1.
Αρ. Γραμμής                    Χ           Υ                        Ε
                1               17
                2                              5
                5                8
                9                                              40
                5                4
                9                                              20
                7                              2
                9                                               8
                5                2             
                9                                               4
                7                              1
                9                                               2

ΘΕΜΑ Γ

     ΠΡΟΓΡΑΜΜΑ ΘΓ
     ΜΕΤΑΒΛΗΤΕΣ
          ΑΚΕΡΑΙΕΣ: Ετ, Φ, Ποσό, MIN
          ΧΑΡΑΚΤΗΡΕΣ: Κ, Τυπ, KMIN
          ΠΡΑΓΜΑΤΙΚΕΣ: ΣΠ
     ΑΡΧΗ
          Φ <-- 0
          ΜΙΝ <-- 3000
          ΣΠ <-- 0
          ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
               ΔΙΑΒΑΣΕ Κ
               ΑΝ Κ < > 'Τ' ΤΟΤΕ
                     ΔΙΑΒΑΣΕ Ετ
                     ΔΙΑΒΑΣΕ Τυπ
                     ΑΝ Κ = 'ΦΟΡΤΗΓΟ' ΤΟΤΕ
                           Φ <-- Φ+1
                           Ποσό <-- 60
                     ΑΛΛΙΩΣ_ΑΝ Κ = 'ΕΠΙΒΑΤΗΓΟ' ΤΟΤΕ
                           Ποσό <-- 40
                     ΑΛΛΙΩΣ
                           Ποσό <-- 20
                     ΤΕΛΟΣ_ΑΝ
                     ΑΝ Τυπ = 'ΕΚΠΡΟΘΕΣΜΟ' ΤΟΤΕ
                           Ποσό <-- Ποσό+15.8
                           ΣΠ <-- ΣΠ+15.8
                     ΤΕΛΟΣ_ΑΝ
                     ΓΡΑΨΕ Ποσό

                     ΑΝ Ετ < ΜΙΝ ΤΟΤΕ
                          ΜΙΝ <-- Ετ
                          ΚΜΙΝ <-- Κ
                     ΤΕΛΟΣ_ΑΝ
                ΤΕΛΟΣ_ΑΝ
          ΜΕΧΡΙΣ_ΟΤΟΥ (Κ = 'Τ')
          ΑΝ  ΜΙΝ < > 3000 ΤΟΤΕ
               ΓΡΑΨΕ Φ, ΚΜΙΝ, ΣΠ
          ΑΛΛΙΩΣ
               ΓΡΑΨΕ 'Δε δόθηκαν δεδομένα'
          ΤΕΛΟΣ_ΑΝ
     ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ 

ΘΕΜΑ Δ
     
     Αλγόριθμος ΘΔ
     Για λ από 1 μέχρι 158
          Διάβασε ΜΕΛΗ[λ]
          Αρχή_επανάληψης
               Διάβασε ΦΥΛΟ[λ]
          Μέχρις_ότου (ΦΥΛΟ]λ] = 'Α') Ή (ΦΥΛΟ[λ] = 'Γ')
     Τέλος_επανάληψης
     Για κ από 1 μέχρι 158
          Για λ από 1 μέχρι 12
               Διάβασε ΒΙΒΛΙΑ[κ, λ]
          Τέλος_επανάληψης
     Τέλος_επανάληψης
     Για κ από 1 μέχρι 158
          SUM[κ] <-- 0
          Για λ από 1 μέχρι 12
               SUM[κ] <-- SUM[κ]+ΒΙΒΛΙΑ[κ, λ]
          Τέλος_επανάληψης
     Τέλος_επανάληψης
     ΒΑ <-- 0
     ΒΓ <-- 0
     Για λ από 1 μέχρι 158
          Αν ΦΥΛΟ[λ] = 'Α' τότε
                ΒΑ <-- ΒΑ+SUM[λ]
          αλλιώς
                ΒΓ <-- ΒΑ+SUM[λ]
          Τέλος_αν
     Τέλος_επανάληψης
     Αν ΒΑ > ΒΓ τότε
          Εμφάνισε 'Περισσότερα βιβλία δανείστηκαν οι άνδρες'
     αλλιώς_αν ΒΑ < ΒΓ τότε
          Εμφάνισε 'Περισσότερα βιβλία δανείστηκαν οι γυναίκες'
     αλλιώς
          Εμφάνισε 'ΙΣΟΣ ΑΡΙΘΜΟΣ ΒΙΒΛΙΩΝ'
     Τέλος_αν
     Διάβασε Επων
     done <-- Ψευδής
     position <-- 0
     λ <-- 1
     Όσο (λ <= 158) ΚΑΙ (done = Ψευδής) επανάλαβε
          Αν ΜΕΛΗ[λ] = Επων τότε
                done <-- Αληθής
                position <-- λ
          αλλιώς
                λ <-- λ+1
          Τέλος_αν
     Τέλος_επανάληψης
     Αν done = Αληθής τότε
           Εμφάνισε SUM[position]
     αλλιώς
           Εμφάνισε 'ΤΟ ΕΠΩΝΥΜΟ ΑΥΤΟ ΔΕΝ ΥΠΑΡΧΕΙ'
     Τέλος_αν
     Τέλος ΘΔ 

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου