Τετάρτη, 26 Μαΐου 2010

Άσκηση : Πορτοφόλι

Έχετε στη διάθεσή σας 200 ευρώ και σκοπεύετε να τα
διαθέσετε για την αγορά αναψυκτικών και ποτών. Γράψτε
πρόγραμμα το οποίο:
α) διαβάζει το είδος ( Α - αναψυκτικό, Π - ποτό) και την
     τιμή κάθε υποψήφιου προς αγορά προϊόντος,
β) ελέγχει αν είναι δυνατή η απόκτησή του και εφόσον
    αυτό συμβαίνει οι αγορές συνεχίζονται, σε διαφορε-
    τική περίπτωση οι αγορές ολοκληρώνονται άμεσα,
γ) υπολογίζει και εμφανίζει:
    1. το πλήθος των αγορασμένων αναψυκτικών και
        ποτών,
    2. το περίσσευμα των χρημάτων σας μετά την ολοκλή-
        ρωση των αγορών,
    3. το συνολικό ποσό που διαθέσατε για τις αγορές σας.
Παραρήρηση : Το πρόγραμμα πρέπει να διασφαλίζει την
εγκυρότητα των εισερχόμενων δεδομένων.

Λύση

     ΠΡΟΓΡΑΜΜΑ Πορτοφόλι
     ΜΕΤΑΒΛΗΤΕΣ
           ΠΡΑΓΜΑΤΙΚΕΣ: Πορτ, Τιμή, Αγ
           ΛΟΓΙΚΕΣ: ΤΕΛ
           ΑΚΕΡΑΙΕΣ: Αναψ, Ποτά
           ΧΑΡΑΚΤΗΡΕΣ: Είδος
     ΑΡΧΗ
           Πορτ <-- 200
           Αναψ <-- 0
           Ποτά <-- 0
           Αγ <-- 0
           ΤΕΛ <-- ΨΕΥΔΗΣ
           ΟΣΟ ΤΕΛ = ΨΕΥΔΗΣ ΕΠΑΝΑΛΑΒΕ
                 ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
                       ΔΙΑΒΑΣΕ Είδος
                 ΜΕΧΡΙΣ_ΟΤΟΥ (Έιδος = 'Α') Ή
                                              (Είδος = ΄Π')
                 ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
                       ΔΙΑΒΑΣΕ Τιμή
                 ΜΕΧΡΙΣ_ΟΤΟΥ Τιμή > 0
                 ΑΝ Τιμή <= Πορτ ΤΟΤΕ
                       Πορτ <-- Πορτ-Τιμή
                       Αγ <-- Αγ+Τιμή
                       ΑΝ Είδος = 'Α' ΤΟΤΕ
                            Αναψ <-- Αναψ+1
                       ΑΛΛΙΩΣ
                            Ποτά <-- Ποτά+1
                       ΤΕΛΟΣ_ΑΝ
                 ΑΛΛΙΩΣ
                       ΤΕΛ <-- ΑΛΗΘΗΣ
                 ΤΕΛΟΣ_ΑΝ
           ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
           ΓΡΑΨΕ Αναψ, Ποτά
           ΑΝ Πορτ > 0 ΤΟΤΕ
                ΓΡΑΨΕ 'Περίσσευμα χρημάτων :', Πορτ
           ΑΛΛΙΩΣ
                ΓΡΑΨΕ 'Δεν υπάρχει καθόλου περίσσευμα'
           ΤΕΛΟΣ_ΑΝ
            ΓΡΑΨΕ Αγ
     ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου