Παρασκευή, 28 Μαΐου 2010

Λύσεις Απολυτήριων εξετάσεων Γ' τάξης Ημερήσιου Γενικού Λυκείου 2010

ΘΕΜΑ Α

Α1.
   1.   
    ΑΝ ΒΑΘΜΟΣ > ΜΟ ΤΟΤΕ
          ΓΡΑΨΕ 'Πολύ καλά'
    ΑΛΛΙΩΣ
          ΑΝ ΒΑΘΜΟΣ <= ΜΟ-2 ΤΟΤΕ
                ΓΡΑΨΕ 'Καλά'
          ΑΛΛΙΩΣ
                ΓΡΑΨΕ 'Μέτρια'
          ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΑΝ

  2.
    ΑΝ (ΤΜΗΜΑ = 'Γ1') ΚΑΙ (ΒΑΘΜΟΣ > 15) ΤΟΤΕ
         ΓΡΑΨΕ ΕΠΩΝΥΜΟ
    ΤΕΛΟΣ_ΑΝ

 3.
    ΑΝ (ΑΠΑΝΤΗΣΗ < > 'Ν') ΚΑΙ (ΑΠΑΝΤΗΣΗ < > 'ν') ΚΑΙ  
           (ΑΠΑΝΤΗΣΗ < > 'Ο') ΚΑΙ (ΑΠΑΝΤΗΣΗ < > 'ο') ΤΟΤΕ
          ΓΡΑΨΕ 'Λάθος απάντηση'
    ΤΕΛΟΣ_ΑΝ

 4.
    ΑΝ (Χ < 0) Ή (ΗΜ(Χ) = 0) ΤΟΤΕ
        ΓΡΑΨΕ 'Λάθος δεδομένα'
    ΑΛΛΙΩΣ
        Υ <-- (Χ^2+5*Χ+1)/(Τ_Ρ(Χ)*ΗΜ(Χ))
         ΓΡΑΨΕ Υ
    ΤΕΛΟΣ_ΑΝ

Α2.
    Τύποι : ΑΚΕΡΑΙΕΣ, ΧΑΡΑΚΤΗΡΕΣ, ΠΡΑΓΜΑΤΙΚΕΣ, ΛΟΓΙΚΕΣ
    Παραδείγματα εντολών εκχώρησης
           Ας θεωρήσουμε τις μεταβλητές Χ, Υ, Ζ, Κ που είναι ακεραίου,
          αλφαριθμητικού, πραγματικού και λογικού τύπου αντίστοιχα.
                Χ <-- 71
                Υ <-- 'καλημέρα'
                Ζ <-- 15.2
                Κ <-- ΨΕΥΔΗΣ

Α3.
     1. Θ
     2. Δ
     3. Η
     4. I
     5. Κ

Α4.
      12. sum <-- sum+table[i, j]
      13. row[i] <-- row[i]+table[i, j]
      14. col[j] <-- col[j]+table[i, j]

A5.
     Για x από 3 μέχρι 19 με_βήμα 2
          Για y από 19 μέχρι x με_βήμα -2
               Αν Π[y] < Π[y-2] τότε
                    Αντιμετάθεσε Π[y], Π[y-2]
               Τέλος_αν
          Τέλος_επανάληψης
     Τέλος_επανάληψης

ΘΕΜΑ Β

     Αριθμός      συνθήκη      έξοδος           i          j
     γραμμής 
          1                                                               1
          2                                                     2
          4                                                     3
          5                                                               2
          6                                      3
          7            Ψευδής
          4                                                     5
          5                                                               3
          6                                      5
          7            Αληθής

ΘΕΜΑ Γ

     Αλγόριθμος ΘΓ
     Αρχή_επανάληψης
          Διάβασε ρέκορ
     Μέχρις_ότου (ρεκόρ > 0) ΚΑΙ (ρεκόρ < 10)
     Διάβασε Πλήθος
     Εμφάνισε 'Δώσε το όνομα του περσινού πρωταθλητή:'
     Διάβασε Ον
     Εμφάνισε 'Δώσε την επίδοσή του:'
     Διάβασε Μέτρα
     ΜετρΠΕΡ <-- Μέτρα
     ΜΙΝ <-- Μέτρα
     ΟνΜΙΝ <-- Ον
     Θέση <-- 1
     flag <-- Ψευδής
     Φ <-- -0
     Για λ από 2 μέχρι Πλήθος
          Διάβασε Ον
          Διάβασε Μέτρα
          Αν Μέτρα < ΜΙΝ τότε
               ΜΙΝ <-- Μέτρα
               ΟνΜΙΝ <-- Ον
          Τέλος_Αν
          Αν Μέτρα > ΜετρΠΕΡ τότε
                Θέση <-- Θέση+1
          Τέλος_αν
          Αν Μέτρα > ρεκόρ τότε
                Εμφάνισε 'Κατέρριψε το ρεκόρ ο :', Ον
                flag <-- Αληθής
          αλλιώς
                Αν (ρεκόρ - Μέτρα) <= 0,5 τότε
                      Φ <-- Φ+1
                Τέλος_αν
          Τέλος_αν
     Τέλος_επανάληψης
     Εμφάνισε ΟνΜΙΝ 
     Αν flag = Ψευδής τότε
          Εμφάνισε Φ
     Τέλος_αν
     Εμφάνισε Θέση
     Τέλος ΘΓ 

ΘΕΜΑ Δ

     
     Αλγόριθμος ΘΔ
     Για  λ από 1 μέχρι 35
          Διάβασε Ον[λ]
          Αρχή_επανάληψης
               Διάβασε Κατ[λ]
          Μέχρις_ότου (Κατ[λ] = 'C1') Ή (Κατ[λ] = 'C2')
                                Ή (Κατ[λ] = 'C3')
          Διάβασε Χρ[λ]
          Διάβασε GPH[λ]
     Τέλος_επανάληψης
     Για λ από 1 μέχρι 35   
          Σχετ[λ] <-- Χρ[λ]/(70*GPH[λ])
      Τέλος_επανάληψης
      Για κ από 2 μέχρι 35
           Για λ από 35 μέχρι κ με_βήμα -1
                Αν Σχετ[λ-1] > Σχετ[λ] τότε
                     Βοηθ <-- Σχετ[λ-1]
                     Σχετ[λ-1] <-- Σχετ[λ]
                     Σχετ[λ] <-- Βοηθ
                     ΤΕΜΡ <-- Ον[λ-1]
                     Ον[λ-1] <-- Ον[λ]
                     Ον[λ] <-- ΤΕΜΡ
                     ΤΕΜΡ <-- Κατ[λ-1]
                     Κατ[λ-1] <-- Κατ[λ]
                     Κατ[λ] <-- ΤΕΜΡ
                     Βοηθ2 <-- Χρ[λ-1]
                     Χρ[λ-1] <-- Χρ[λ]
                     Χρ[λ] <-- Βοηθ2
                     Βοηθ2 <-- GPH[λ-1]
                     GPH[λ-1] <-- GPH[λ]
                     GPH[λ] <-- Βοηθ2
                Τέλος_αν
           Τέλος_επανάληψης
      Τέλος_επανάληψης
      π1 <-- 0
      π2 <-- 0
      π3 <-- 0
      Για λ από 1 μέχρι 35
           Αν Κατ[λ] = 'C1' τότε
                π1 <-- π1+1
                OC1[π1] <-- Oν[λ]
           αλλιώς_αν Κατ[λ] = 'C2' τότε
                π2 <-- π2+1
                OC2[π2] <-- Oν[λ]
           αλλιώς
                π3 <-- π3+1
                OC3[π3] <-- Oν[λ]
           Τέλος_αν
      Τέλος_επανάληψης
      ΜΑΧ <-- π1
      ΚΜΑΧ <-- 'C1'
      Αν π2 > ΜΑΧ τότε
           ΜΑΧ <-- π2
           ΚΜΑΧ <-- 'C2'
      Τέλος_αν
      Αν π3 > ΜΑΧ τότε
           ΜΑΧ <-- π3
           ΚΜΑΧ <-- 'C3'
      Τέλος_αν
      Εμφάνισε ΚΜΑΧ
      Εμφάνισε 'Τα  3 πρώτα σκάφη της γενικής κατάταξης είναι...'
      Για λ από 1 μέχρι 3
            Εμφάνισε Ον[λ]
      Τέλος_επανάληψης
      Εμφάνισε 'Τα 3 πρώτα σκάφη στην κατηγορία C1 είναι ...'
      Για λ από 1 μέχρι 3
           Εμφάνισε OC1[λ]
       Τέλος_επανάληψης
       Εμφάνισε 'Τα 3 πρώτα σκάφη στην κατηγορία C2 είναι ...'
       Για λ από 1 μέχρι 3
           Εμφάνισε OC2[λ]
       Τέλος_επανάληψης
       Εμφάνισε 'Τα 3 πρώτα σκάφη στην κατηγορία C3 είναι ...'
       Για λ από 1 μέχρι 3

           Εμφάνισε OC3[λ] 
       Τέλος_επανάληψης
       Τέλος ΘΔ

2 σχόλια:

  1. Συνάδελφε καλησπέρα ,
    θα ήθελα να σε ρωτήσω τι εννοείς λέγοντας ότι στο ΘΕΜΑ Γ θα μπορούσαν να χρησιμοποιηθούν πίνακες υπό προϋποθέσεις.
    Ποιες είναι αυτές;

    Οι περισσότεροι μαθητές μου έλυσαν το συγκεκριμένο θέμα με τη χρήση πινάκων και είναι ανάστατοι με τις λύσεις που δίνονται από τα ΜΜΕ.

    Σε ευχαριστώ για το χρόνο σου

    ΑπάντησηΔιαγραφή
  2. Σύμφωνα με το σχολικό βιβλίο, η χρήση πίνακα προβλέπεται μόνο όταν γνωρίζουμε τον ακριβή αριθμό των δεδομένων ή το ανώτατο όριο του πλήθους τους. Στην εκφώνηση δεν αναφέρεται κάτι τέτοιο και τυπικά η λύση με πίνακες δεν είναι 100% σωστή. Μάλιστα δόθηκε στους βαθμολογητές οδηγία από το υπουργείο(το τρωκτικό έχει σχετικό άρθρο) η οποία αναφέρει ότι η χρήση των πινάκων στο τρίτο θέμα δεν είναι ορθή, προτείνει σε αυτούς ωστόσο να αποφασίσουν (επί της ουσίας) πόσες μονάδες θα κόψουν από τον υποψήφιο. Συνεπώς η τελική βαθμολόγηση των υποψηφίων θα εξαρτηθεί από το βαθμολογικό κέντρο που θα πάνε τα γραπτά τους (αφού το "μπαλάκι" πέφτει ουσιαστικά στους ίδιους τους βαθμολογητές).

    ΑπάντησηΔιαγραφή