Πέμπτη, 20 Μαΐου 2010

Άσκηση : Μέγιστα και ελάχιστα ανά γραμμή ή ανά στήλη

Θεωρήστε τον πίνακα  ΧΡΟΝΟΙ[10, 5] που περιέχει τους
χρόνους που πέτυχαν 10 δρομείς στο αγώνισμα των 100μ.
σε 5 διεθνή τουρνουά. Γράψτε αλγόριθμο που με δεδομένο
τον παραπάνω πίνακα, υπολογίζει και εμφανίζει:
α) την καλύτερη επίδοση κάθε δρομέα και τον αύξοντα
     αριθμό (1-5) του τουρνουά στο οποίο την πέτυχε (όλες
     οι επιδόσεις των αθλητών είναι διαφορετικές μεταξύ
     τους),
β) τη χειρότερη επίδοση για κάθε τουρνουά και τον αύξοντα
    αριθμό (1-10) του δρομέα που την πέτυχε(θεωρήστε ότι
    είναι μοναδικός).


Λύση

     Αλγόριθμος Δρομείς
     Δεδομένα // ΧΡΟΝΟΙ //
     Για λ από 1 μέχρι 10
          Καλ <-- ΧΡΟΝΟΙ[λ, 1]
          ΘΚαλ <-- 1
          Για ρ από 2 μέχρι 5
                Αν ΧΡΟΝΟΙ[λ, ρ] < Καλ τότε
                      Καλ <-- ΧΡΟΝΟΙ[λ, ρ]
                      ΘΚαλ <-- ρ
                Τέλος_αν
          Τέλος_επανάληψης
          Γράψε Καλ, ΘΚαλ
     Τέλος_επανάληψης
     Για ρ από 1 μέχρι 5
          Χειροτ  <-- ΧΡΟΝΟΙ[1, ρ]
          ΘΧειρ <-- 1
          Για λ από 2 μέχρι 10
                Αν ΧΡΟΝΟΙ[λ, ρ] > Χειροτ τότε
                      Χειροτ <-- ΧΡΟΝΟΙ[λ, ρ]
                      ΘΧειρ <-- λ
                Τέλος_αν
          Τέλος_επανάληψης
          Γράψε Χειροτ, ΘΧειρ
     Τέλος_επανάληψης
     Τέλος Δρομείς

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου