Τετάρτη, 26 Μαΐου 2010

Άσκηση : Κουμπαράς

Έχετε ως στόχο να αγοράσετε ένα αυτοκίνητο αξίας 9000
ευρώ. Για το σκοπό αυτό αποταμιεύετε καθημερινά κάποιο
χρηματικό ποσό. Γράψτε πρόγραμμα το οποίο:
α) διαβάζει το ποσό που αποταμιεύετε καθημερινά
    (μέχρι να συγκεντρώσετε το απαιτούμενο για την
     αγορά χρηματικό ποσό),
β) υπολογίζει και εμφανίζει:
    * πόσες ημέρες απαιτούνται μέχρι να ολοκληρωθεί η
       αγορά του αυτοκινήτου,
    * το περίσσευμα των χρημάτων σας (εφόσον αυτό
       υπάρχει)
Παρατήρηση: Δεν απαιτείται κανένας έλεγχος εγκυρότητας
των εισερχόμενων δεδομένων.

Λύση

    ΠΡΟΓΡΑΜΜΑ Κουμπαράς
    ΜΕΤΑΒΛΗΤΕΣ
          ΠΡΑΓΜΑΤΙΚΕΣ: Σύνολο, Ποσό, Περίσσευμα
          ΑΚΕΡΑΙΕΣ: Ημέρες
    ΑΡΧΗ
          Ημέρες <-- 0
          Σύνολο <-- 0
          ΟΣΟ Σύνολο < 9000 ΕΠΑΝΑΛΑΒΕ
                ΔΙΑΒΑΣΕ Ποσό
                Σύνολο <-- Σύνολο+Ποσό
                Ημέρες <-- Ημέρες+1
          ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
          ΓΡΑΨΕ Ημέρες
          Περίσσευμα <-- Σύνολο-9000
          ΑΝ Περίσσευμα > 0 ΤΟΤΕ
               ΓΡΑΨΕ 'Περίσσευμα = ', Περίσσευμα
          ΑΛΛΙΩΣ
               ΓΡΑΨΕ 'Δεν υπάρχει καθόλου περίσσευμα'
          ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου