Πέμπτη, 20 Μαΐου 2010

Άσκηση : γέμισμα μονοδιάστατου πίνακα

Γράψτε αλγόριθμο που να γεμίζει τον πίνακα Σ[10] με
τις τιμές : 10, 20, 30, ...., 100.

Λύση

      α' τρόπος

      Αλγόριθμος Γέμισμα
      Για ρ από 1 μέχρι 10
          Σ[ρ] <-- ρ*10
      Τέλος_επανάληψης
      Αποτελέσματα  // Σ //
      Τέλος Γέμισμα

      β' τρόπος

      Αλγόριθμος Γέμισμα2
      Υ <-- 10
      Για ρ από 1 μέχρι 10
          Σ[ρ] <-- Υ
          Υ <-- Υ+10
      Τέλος_επανάληψης
      Αποτελέσματα  // Σ //
      Τέλος Γέμισμα2

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου