Δευτέρα, 17 Μαΐου 2010

Άσκηση : Ποιά είναι η τελική τιμή της μεταβλητής β;

Ποιά είναι η τελική τιμή της μεταβλητής β μετά την εκτέλεση
των παρακάτω εντολών;
      β <-- 11
      Για κ από 2 μέχρι 13 με_βήμα 4
          Για γ από 15 μέχρι 7 με_βήμα -1
                β <-- β+5
          Τέλος_επανάληψης
     Τέλος_επανάληψης

Απάντηση
     Η εξωτερική Για..από..μέχρι εκτελείται 3 φορές, ενώ το
     πλήθος των επαναλήψεων τις εσωτερικής Για..από..μέχρι
     είναι 9.  Κατά συνέπεια η εντολή β <-- β+5 εκτελείται
     συνολικά 3Χ9 = 27 φορές και έτσι η τελική τιμή της
     μεταβλητής β  είναι : 11+27Χ5 = 11+135 = 146.

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου