Κυριακή, 16 Μαΐου 2010

Άσκηση : Απλοποιήστε ένα σύνολο εντολών

Ξαναγράψτε το παρακάτω σύνολο εντολών έτσι ώστε αυτό να μην
περιέχει περιττούς ελέγχους ή εντολές που δεν πρόκειται ποτέ
να εκτελεστούν:
     Διάβασε μ, ν
     Αν  μ > ν τότε
          α <-- μ-ν
          Αν α > 0 τότε
               β <-- 2*α
          αλλιώς
               β <-- α^2
          Τέλος_αν
    αλλιώς_αν μ < ν τότε
          α <-- ν-μ
          Αν α mod 2 = 2 τότε
               β <-- 100*α
          αλλιώς_αν α mod 2 = 1 τότε
               β <-- 200*α
          αλλιώς
              β <-- 300*α
          Τέλος_αν

    αλλιώς
           Αν μ = ν τότε
                 β <-- 400*α
           Τέλος_αν
    Τέλος_αν

Λύση
     
     Διάβασε μ, ν
     Αν  μ > ν τότε
          α <-- μ-ν
          β <-- 2*α   
     αλλιώς_αν μ < ν τότε
          α <-- ν-μ
          Αν α mod 2 = 1 τότε
               β <-- 200*α
          αλλιώς
               β <-- 300*α
          Τέλος_αν
    αλλιώς
           β <-- 400*α
    Τέλος_αν

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου