Παρασκευή, 28 Μαΐου 2010

Εναλλακτική λύση του ΘΕΜΑΤΟΣ Γ των Απολυτήριων εξετάσεων Ημερήσιου Γενικού Λυκείου 2010

Επειδή έχει ξεκινήσει ήδη μια μεγάλη συζήτηση για το ΘΕΜΑ Γ
και για το αν μπορούσε ο υποψήφιος να χρησιμοποιήσει ή όχι
πίνακα, παραθέτω μια λύση με πίνακες, που υπό προϋποθέσεις
μπορεί να γίνει αποδεκτή στο σύνολό της.




! Υποθέτουμε ότι το ανώτατο πλήθος αθλητών που δήλωσαν
! συμμετοχή είναι 5000
Αλγόριθμος ΘΓ_2οςΤΡΟΠΟΣ
! Ον[5000] : τα ονοματεπώνυμα των αθλητών
! Μέτρα[5000] : οι επιδόσεις τους
Αρχή_επανάληψης
      Διάβασε ρεκόρ
Μέχρις_ότου (ρεκόρ > 0) ΚΑΙ (ρεκόρ < 10)
Διάβασε Πλήθος
Για λ από 1 μέχρι Πλήθος
      Διάβασε Ον[λ]
      Διάβασε Μέτρα[λ]
Τέλος_επανάληψης
ΟνΠΕΡΣ <-- Ον[1]
ΜΙΝ <-- Μέτρα[1]
ΑΑΜΙΝ <-- 1
Για λ από 2 μέχρι Πλήθος
      Αν Μέτρα[λ] < ΜΙΝ τότε
            ΜΙΝ <-- Μέτρα[λ]
            ΑΑΜΙΝ <-- λ
      Τέλος_αν
Τέλος_επανάληψης
Εμφάνισε Ον[ΑΑΜΙΝ]
Κατ <-- 0
Φ <-- 0
Για λ από 1 μέχρι Πλήθος
      Αν Μέτρα[λ] > ρεκόρ τότε
           Εμφάνισε 'Κατέρριψε το ρεκόρ ο :', Ον[λ]
           Κατ <-- Κατ+1
      αλλιώς
            Αν (ρεκόρ-Μέτρα[λ]) <= 0.5 τότε
                 Φ <-- Φ+1
            Τέλος_αν
      Τέλος_αν
Τέλος_επανάληψης
Αν Κατ = 0 τότε
      Εμφάνισε Φ
Τέλος_αν
Για κ από 2 μέχρι Πλήθος
     Για λ από Πλήθος μέχρι κ με_βήμα -1
          Αν Μέτρα[Λ-1] < Μέτρα[Λ] τότε
               Βοηθ <-- Μέτρα[Λ-1]
               Μέτρα[Λ-1] <-- Μέτρα[Λ]
               Μέτρα[Λ] <-- Βοηθ
               ΤΕΜΡ <--- Ον[λ-1]
               Ον[λ-1] <-- Ον[λ]
               Ον[λ] <-- ΤΕΜΡ
          Τέλος_αν
     Τέλος_επανάληψης
Τέλος_επανάληψης
done <-- Ψευδής
position <-- 0
λ <-- 1
Όσο (λ <= Πλήθος) ΚΑΙ (done = Ψευδής) επανάλαβε
      Αν Ον[λ] = ΟνΠΕΡΣ τότε
            done <-- Αληθής
            position <-- λ
      αλλιώς
            λ <-- λ+1
      Τέλος_αν
Τέλος_επανάληψης
Εμφάνισε 'Θέση περσινού πρωταθλητή :', position
Τέλος ΘΓ_2οςΤΡΟΠΟΣ

Παρατήρηση : Η μέθοδος έχει ως μοναδικό αδύναμο σημείο της
την αρχική υπόθεση για το μέγιστο δυνατό πλήθος των στοιχείων
του πίνακα που όπως είναι προφανές είναι αυθαίρετο και δε
συνάγεται από πουθενά. Ωστόχο επειδή ο σχεδιασμός των
αλγορίθμων δεν έχει τις δεσμευτικές δεικλίδες των προγραμ-
μάτων (στα οποία πρέπει να προσδιορίσεις επακριβώς το σύνολο
της μνήμης που θα χρειαστείς για την ανάπτυξη της εφαρμογής
σου) θεωρώ ότι και η λύση αυτή είναι επιστημονικά τεκμηριω-
μένη και σωστή.

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου